Kodierung/DekodierungWerkzeuge
Daten in verschiedenen Formaten kodieren und dekodieren: Base64, URL, Hex, Binary, HTML-Entity, Unicode, Base32/58/85 und mehr.
69 Tools verfügbar, alle lokal im Browser.
- ASCII-TabelleComplete ASCII reference table (0-127) with decimal, hex, octal, binary, and character. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Ascii85-DekodiererAscii85 Decode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Ascii85-KodiererAscii85 Encode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Zahlbasis-KonverterConvert numbers between any base (2-36). Kostenlos, privat, 100% clientseitig.WERKZEUG
- Base100-DekodiererBase100 Decode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Base100-KodiererBase100 Encode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Base2048-DekodiererBase2048 Decode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Base2048-KodiererBase2048 Encode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Base32-DekodiererDecode Base32 (RFC 4648) back to readable text online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Base32-KodiererEncode text to Base32 (RFC 4648) online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Base36-DekodiererBase36 Decode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Base36-KodiererBase36 Encode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Base58-DekodiererDecode Base58 (Bitcoin alphabet) back to readable text online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Base58-KodiererEncode text to Base58 (Bitcoin alphabet) online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Base62-DekodiererBase62 Decode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Base62-KodiererBase62 Encode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Base64-DekodiererDecode Base64 data back to readable text online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Base64-KodiererEncode text or binary data to Base64 online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Base85-DekodiererDecode Ascii85 (Base85) back to readable text online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Base85-KodiererEncode text to Ascii85 (Base85) online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Base91-DekodiererDecode Base91 encoded text. Kostenlos, privat, 100% clientseitig.WERKZEUG
- Base91-KodiererEncode text to Base91. Kostenlos, privat, 100% clientseitig.WERKZEUG
- Binär-DekodiererDecode binary (base-2) back to readable text online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Binär-KodiererEncode text to binary (base-2) online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Zeichensatz-ReferenzReference table of character encodings. Kostenlos, privat, 100% clientseitig.WERKZEUG
- GSM-DekodiererGsm Decode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- GSM-KodiererKodiert Text zu GSM-03.38-Hex per ZeichenNachschlage-Tabelle des Standardalphabets (@ → 00, A → 41). Jedes Zeichen belegt ein Byte — keine SMS-7-Bit-Packung, die Ausgabe ist also kein PDU; Nicht-GSM-Zeichen fallen auf UTF-8-Bytes zurück.WERKZEUG
- Hex-DekodiererDecode hexadecimal back to readable text online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Hex-KodiererEncode text to hexadecimal online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- HTML-Entity-DekodiererDecode HTML entities back to readable text online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- HTML-Entity-KodiererEncode text to HTML entities online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- JWT-KodiererCodieren JWT with HS256. Free, private, 100% client-side. Not for server-side verification.WERKZEUG
- MIME-Header-DekodiererMime Decode Header — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- MIME-DekodiererDecode MIME-encoded text (Base64 or Quoted-Printable) back to original content. Kostenlos, privat und 100% clientseitig.WERKZEUG
- MIME-Header-KodiererMime Encode Header — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- MIME-KodiererEncode text to MIME format (Base64 or Quoted-Printable) for email content. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Morsecode-KonverterConvert text to Morse code and back. Kostenlos, privat, 100% clientseitig.WERKZEUG
- Multibase-DekodiererMultibase Decode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Multibase-KodiererMultibase Encode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Oktal-DekodiererConvert octal (base-8) bytes back to text. Kostenlos, privat, 100% clientseitig.WERKZEUG
- Oktal-KodiererConvert text to octal (base-8) byte representation. Kostenlos, privat, 100% clientseitig.WERKZEUG
- PCT-DekodiererPct Decode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- PCT-KodiererPct Encode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Punycode-DekodiererDecode Punycode (RFC 3492) text back to Unicode. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Punycode-KodiererEncode Unicode text to Punycode (RFC 3492) with ACE prefix. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Quoted-Printable-DekodiererDecode Quoted-Printable text back to original content. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Quoted-Printable-KodiererEncode text to Quoted-Printable format (RFC 2045). Kostenlos, privat und 100% clientseitig.WERKZEUG
- ROT13 / Cäsar-VerschlüsselungROT13 and configurable Caesar cipher for text. Kostenlos, privat, 100% clientseitig.WERKZEUG
- Unicode-KonverterConvert text to Unicode code points, UTF-8 hex, or UTF-16 hex online. Kostenlos, privat und 100% clientseitig.WERKZEUG
- Unicode-EscapeUnicode Escape — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Unicode-UnescapeUnicode Unescape — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- URL-Komponenten-DekodiererUrl Decode Component — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- URL-Formular-DekodiererUrl Decode Form — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- URL-DekodiererDecode percent-encoded URL text back to readable characters. Kostenlos, privat und 100% clientseitig.WERKZEUG
- URL-Komponenten-KodiererUrl Encode Component — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- URL-Formular-KodiererUrl Encode Form — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- URL-KodiererPercent-encode text for safe use in URLs. Kostenlos, privat und 100% clientseitig.WERKZEUG
- UTF-16 zu UTF-8Utf16 To Utf8 — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- UTF-7-DekodiererDekodiert modifiziertes UTF-7 (RFC 2152) zurück zu Text: +base64--Shift-Sequenzen werden zu ihren Zeichen. Bekannte Einschränkung: Die „+-“-Escape für ein literales Plus ergibt nichts statt „+“.WERKZEUG
- UTF-7-KodiererKodiert Text zu modifiziertem UTF-7 (RFC 2152): ASCII passiert unverändert, Nicht-ASCII wird zu +base64--Shift-Blöcken. Beachte: „+“ selbst wird als Shift-Sequenz „+ACs-“ statt in der kürzeren Form „+-“ kodiert, und aufeinanderfolgende Nicht-ASCII-Zeichen können als getrennte Blöcke ausgegeben werden.WERKZEUG
- UTF-8 zu UTF-16Utf8 To Utf16 — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- UUdecode-DekodiererDecode UUencoded text. Kostenlos, privat, 100% clientseitig.WERKZEUG
- UUencode-KodiererUUencode text for Unix-to-Unix transfer. Kostenlos, privat, 100% clientseitig.WERKZEUG
- Xxdecode-DekodiererDekodiert xxencode-Text, der vom XXEncode-Werkzeug dieser Seite erzeugt wurde. Standardmäßige xxencode-Ausgabe mit Zeilenlängen-Präfixzeichen wird nicht unterstützt — das Präfix würde als Daten dekodiert.WERKZEUG
- Xxencode-KodiererKodiert Text mit dem xxencode-Zeichensatz (+ - 0-9 A-Z a-z) per 3-zu-4-Gruppierung. Es werden keine standardmäßigen Zeilenlängen-Präfixzeilen ausgegeben — die Ausgabe rundet möglicherweise nicht mit anderen xxencode-Implementierungen.WERKZEUG
- Ydecode-DekodiererDekodiert yEnc-Text (Zeichenoffset -42, „=“ als Escape). Grenzfall: Ein einzelnes „=“ am Ende wird zu einem unerwarteten Byte dekodiert, statt einen Fehler auszulösen.WERKZEUG
- Yencode-KodiererYencode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Z85-DekodiererZ85 Decode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG
- Z85-KodiererZ85 Encode — reines Client-seitiges Tool. Datenschutz zuerst, kein Server-Roundtrip.WERKZEUG