技術参考資料 200
チートシート、クイックリファレンス、仕様の要約——エンコーディング、フォーマット、開発ワークフローに関する参照資料。
暗号/セキュリティ 28
- AES ブロック 暗号 モード リファレンス
- Authenticated 暗号化 (AEAD) リファレンス
- Authenticated 暗号化 モード (AEAD)
- ブロック 暗号 リファレンス ガイド
- Camellia ブロック 暗号 Specification
- ChaCha20 Stream 暗号 Specification
- 暗号 アルゴリズム 比較
- Cryptographic Attack 型 リファレンス
- Cryptographic 鍵 Management リファレンス
- Cryptographic 鍵 サイズ Recommendations
- ECDH (Elliptic Curve Diffie-Hellman) リファレンス
- ECDSA (Elliptic Curve Digital 署名 アルゴリズム) リファレンス
- Elliptic Curve Cryptography リファレンス
- HKDF 仕様 (RFC 5869)
- Homomorphic 暗号化 リファレンス
- Lattice-Based Cryptography リファレンス
- NIST Cryptographic Standards リファレンス
- Padding Schemes リファレンス
- Post-Quantum Cryptography リファレンス
- Provable セキュリティ リファレンス
- RSA 鍵 Formats リファレンス
- Salsa20 Stream 暗号 Specification
- Secret Sharing Schemes リファレンス
- Serpent ブロック 暗号 Specification
- Side-Channel Attack リファレンス
- Stream 暗号 リファレンス ガイド
- Twofish ブロック 暗号 Specification
- Zero-Knowledge Proof リファレンス
エンコード/デコード 10
フォーマット/変換 33
- Apache Avro 仕様
- Apple プロパティ List (plist) 整形 ガイド
- Atom Syndication 整形 Specification
- CBOR (Concise Binary オブジェクト Representation) Specification
- CSV 整形 RFC 4180
- Environment Variable ファイル (.env) 整形 ガイド
- Frontmatter (YAML/TOML/JSON) ガイド
- GraphQL クエリ Language リファレンス
- GraphQL スキーマ 定義 リファレンス
- HATEOAS / HAL 仕様
- HJSON (Human JSON) 仕様
- INI ファイル 整形 ガイド
- INI 整形 リファレンス
- Java プロパティ ファイル 整形 ガイド
- JSON RFC 8259 仕様
- JSON スキーマ Draft 2020-12
- JSON:API 仕様
- JSON5 仕様
- JSONC (JSON 付き Comments) Specification
- MessagePack 仕様
- NDJSON (Newline Delimited JSON) 仕様
- OpenAPI Specification リファレンス
- Protocol Buffers エンコード リファレンス
- Protocol Buffers 仕様
- RSS 2.0 仕様
- SVG Path データ リファレンス
- TOML 整形 Specification
- XML Namespace ガイド
- XML Namespace リファレンス
- XPath リファレンス
- XQuery リファレンス
- XSLT リファレンス
- YAML 1.2 仕様
ハッシュ/チェックサム 21
- Argon2 Specification リファレンス
- BLAKE Family リファレンス
- Checksum アルゴリズム リファレンス
- Cryptographically 安全 Random 数値 リファレンス
- Entropy および 情報 理論 リファレンス
- ハッシュ アルゴリズム 出力 Sizes
- ハッシュ 関数 比較 リファレンス
- ハッシュ 関数 セキュリティ プロパティ
- ハッシュ Performance Benchmarking リファレンス
- HMAC (Keyed-ハッシュ メッセージ Authentication) リファレンス
- HMAC Construction 詳細 (RFC 2104)
- Keccak Permutation リファレンス
- 鍵 Derivation 関数 リファレンス
- Merkle ハッシュ Tree リファレンス
- Non-Cryptographic ハッシュ リファレンス
- Parallel および Tree Hashing リファレンス
- パスワード Hashing 比較
- パスワード Hashing リファレンス
- SHA-2 Family リファレンス
- SHA-3 Family リファレンス
- Sponge Construction リファレンス
数学/単位 10
ネットワーク/IP 31
- CORS (Cross-Origin Resource Sharing) リファレンス
- CORS Headers リファレンス
- DNS Protocol リファレンス
- DTLS Protocol リファレンス
- Ethernet および ARP リファレンス
- gRPC Protocol リファレンス
- HTTP セキュリティ Headers リファレンス
- HTTP Status Codes 完了 リファレンス
- HTTP/1.1 リファレンス
- HTTP/2 リファレンス
- HTTP/3 リファレンス
- ICE Protocol リファレンス
- IP Protocol リファレンス
- JSON-RPC 2.0 仕様
- MIME 型 完了 List
- MQTT Protocol リファレンス
- NAT (Network Address Translation) リファレンス
- OCSP Protocol リファレンス
- Port 数値 リファレンス
- QUIC Protocol リファレンス
- REST API Design リファレンス
- RTP Protocol リファレンス
- SDP (Session 説明 Protocol) リファレンス
- SOAP Protocol リファレンス
- STUN Protocol リファレンス
- TCP Protocol リファレンス
- TLS 1.3 リファレンス
- UDP Protocol リファレンス
- URL 構文 RFC 3986
- WebSocket Protocol リファレンス
- X.509 Certificate 整形 リファレンス
正規表現 20
- 文字 エンコード History リファレンス
- 一般的 Regex パターン リファレンス
- Regex 高度 Syntax リファレンス
- Regex 文字 クラス リファレンス
- Regex Date および Time パターン リファレンス
- Regex Email パターン リファレンス
- Regex Engine 比較 リファレンス
- Regex Flags リファレンス
- Regex IP Address パターン リファレンス
- Regex Performance ガイド
- Regex Phone 数値 パターン リファレンス
- Regex Quantifiers リファレンス
- Regex Syntax チートシート
- Regex Unicode リファレンス
- Regex URL パターン リファレンス
- 文字列 アルゴリズム リファレンス
- テキスト エンコード リファレンス
- Unicode Collation リファレンス
- Unicode Normalization リファレンス
- Unicode プロパティ Escapes で Regex
セキュリティ 25
- API セキュリティ Best Practices リファレンス
- Content セキュリティ Policy (CSP) リファレンス
- Cookie セキュリティ リファレンス
- CORS セキュリティ リファレンス
- Cryptographic Standards リファレンス
- CSRF Prevention リファレンス
- CVE (一般的 Vulnerabilities および Exposures) リファレンス
- CVSS (Vulnerability Scoring) リファレンス
- CWE (一般的 Weakness Enumeration) リファレンス
- HSTS (HTTP Strict Transport セキュリティ) リファレンス
- Insecure Deserialization Prevention リファレンス
- JWT セキュリティ リファレンス
- NIST 鍵 Management リファレンス
- OAuth 2.0 リファレンス
- OpenID Connect リファレンス
- OWASP API 上 10 リファレンス
- OWASP 上 10 リファレンス
- パスワード Storage リファレンス
- Post-Quantum アルゴリズム リファレンス
- Rate Limiting リファレンス
- Side-Channel Mitigation リファレンス
- SQL Injection Prevention リファレンス
- SSRF Prevention リファレンス
- Subresource Integrity (SRI) リファレンス
- XSS Prevention リファレンス
SQL 19
- ACID vs BASE Semantics リファレンス
- CAP Theorem および NoSQL リファレンス
- データベース Normalization リファレンス
- データベース Sharding および Partitioning リファレンス
- NoSQL データベース 比較
- SQL Clause リファレンス
- SQL Constraint リファレンス
- SQL データ 型 リファレンス
- SQL 関数 リファレンス
- SQL 関数 リファレンス
- SQL Index リファレンス
- SQL JOIN リファレンス
- SQL Keywords 完了 リファレンス
- SQL Operator リファレンス
- SQL 標準 リファレンス
- SQL Subquery および CTE リファレンス
- SQL Transaction および Isolation リファレンス
- SQL Trigger リファレンス
- SQL Window 関数 リファレンス