エンコード/デコードツール
Base64、URL、Hex、Binary、HTMLエンティティ、Unicode、Base32/58/85 など多様な形式のエンコード・デコードを行います。
69 個のツールが利用可能、すべてブラウザローカルで実行。
- ASCII コード表Complete ASCII reference table (0-127) with decimal, hex, octal, binary, and character。無料、プライベート、100%クライアントサイド。ツール
- Ascii85 デコーダーAscii85 Decode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Ascii85 エンコーダーAscii85 Encode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- 基数変換ツールConvert numbers between any base (2-36)。無料、プライベート、100%クライアントサイド。ツール
- Base100 デコーダーBase100 Decode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Base100 エンコーダーBase100 Encode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Base2048 デコーダーBase2048 Decode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Base2048 エンコーダーBase2048 Encode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Base32 デコーダーDecode Base32 (RFC 4648) back to readable text online。無料、プライベート、100%クライアントサイド。ツール
- Base32 エンコーダーEncode text to Base32 (RFC 4648) online。無料、プライベート、100%クライアントサイド。ツール
- Base36 デコーダーBase36 Decode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Base36 エンコーダーBase36 Encode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Base58 デコーダーDecode Base58 (Bitcoin alphabet) back to readable text online。無料、プライベート、100%クライアントサイド。ツール
- Base58 エンコーダーEncode text to Base58 (Bitcoin alphabet) online。無料、プライベート、100%クライアントサイド。ツール
- Base62 デコーダーBase62 Decode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Base62 エンコーダーBase62 Encode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Base64 デコーダーDecode Base64 data back to readable text online。無料、プライベート、100%クライアントサイド。ツール
- Base64 エンコーダーEncode text or binary data to Base64 online。無料、プライベート、100%クライアントサイド。ツール
- Base85 デコーダーDecode Ascii85 (Base85) back to readable text online。無料、プライベート、100%クライアントサイド。ツール
- Base85 エンコーダーEncode text to Ascii85 (Base85) online。無料、プライベート、100%クライアントサイド。ツール
- Base91 デコーダーDecode Base91 encoded text。無料、プライベート、100%クライアントサイド。ツール
- Base91 エンコーダーEncode text to Base91。無料、プライベート、100%クライアントサイド。ツール
- バイナリデコーダーDecode binary (base-2) back to readable text online。無料、プライベート、100%クライアントサイド。ツール
- バイナリエンコーダーEncode text to binary (base-2) online。無料、プライベート、100%クライアントサイド。ツール
- 文字コードリファレンスReference table of character encodings。無料、プライベート、100%クライアントサイド。ツール
- GSM デコーダーGsm Decode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- GSM エンコーダーGSM 03.38 のデフォルトアルファベットを 1 文ずつ参照して hex にエンコードします(@ → 00、A → 41)。各文字は 1 バイトになり、SMS の 7 ビットパッキングは行われないため、出力は PDU ではありません。GSM 未対応の文字は UTF-8 バイトにフォールバックします。ツール
- HEX デコーダーDecode hexadecimal back to readable text online。無料、プライベート、100%クライアントサイド。ツール
- HEX エンコーダーEncode text to hexadecimal online。無料、プライベート、100%クライアントサイド。ツール
- HTML エンティティデコーダーDecode HTML entities back to readable text online。無料、プライベート、100%クライアントサイド。ツール
- HTML エンティティエンコーダーEncode text to HTML entities online。無料、プライベート、100%クライアントサイド。ツール
- JWT エンコーダーエンコード JWT with HS256. Free, private, 100% client-side. Not for server-side verification.ツール
- MIME ヘッダーデコーダーMime Decode Header — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- MIME デコーダーDecode MIME-encoded text (Base64 or Quoted-Printable) back to original content。無料、プライベート、100%クライアントサイド。ツール
- MIME ヘッダーエンコーダーMime Encode Header — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- MIME エンコーダーEncode text to MIME format (Base64 or Quoted-Printable) for email content。無料、プライベート、100%クライアントサイド。ツール
- モールス符号コンバーターConvert text to Morse code and back。無料、プライベート、100%クライアントサイド。ツール
- Multibase デコーダーMultibase Decode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Multibase エンコーダーMultibase Encode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- 8進数デコーダーConvert octal (base-8) bytes back to text。無料、プライベート、100%クライアントサイド。ツール
- 8進数エンコーダーConvert text to octal (base-8) byte representation。無料、プライベート、100%クライアントサイド。ツール
- PCT デコーダーPct Decode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- PCT エンコーダーPct Encode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Punycode デコーダーDecode Punycode (RFC 3492) text back to Unicode。無料、プライベート、100%クライアントサイド。ツール
- Punycode エンコーダーEncode Unicode text to Punycode (RFC 3492) with ACE prefix。無料、プライベート、100%クライアントサイド。ツール
- Quoted-Printable デコーダーDecode Quoted-Printable text back to original content。無料、プライベート、100%クライアントサイド。ツール
- Quoted-Printable エンコーダーEncode text to Quoted-Printable format (RFC 2045)。無料、プライベート、100%クライアントサイド。ツール
- ROT13 / シーザー暗号ROT13 and configurable Caesar cipher for text。無料、プライベート、100%クライアントサイド。ツール
- Unicode コンバーターConvert text to Unicode code points, UTF-8 hex, or UTF-16 hex online。無料、プライベート、100%クライアントサイド。ツール
- Unicode エスケープUnicode Escape — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Unicode アンエスケープUnicode Unescape — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- URL コンポーネントデコーダーUrl Decode Component — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- URL フォームデコーダーUrl Decode Form — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- URL デコーダーDecode percent-encoded URL text back to readable characters。無料、プライベート、100%クライアントサイド。ツール
- URL コンポーネントエンコーダーUrl Encode Component — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- URL フォームエンコーダーUrl Encode Form — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- URL エンコーダーPercent-encode text for safe use in URLs。無料、プライベート、100%クライアントサイド。ツール
- UTF-16 から UTF-8 への変換Utf16 To Utf8 — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- UTF-7 デコーダー修正 UTF-7(RFC 2152)をテキストにデコードします。+base64- シフトシーケンスが対応する文字に戻ります。既知の制限: リテラルのプラス記号を表す「+-」エスケープは「+」ではなく空にデコードされます。ツール
- UTF-7 エンコーダーテキストを修正 UTF-7(RFC 2152)にエンコードします。ASCII はそのまま通過し、非 ASCII は +base64- シフトブロックになります。「+」自体はより短い「+-」形式ではなくシフトシーケンス「+ACs-」としてエンコードされ、連続する非 ASCII 文字は別々のブロックとして出力されることがあります。ツール
- UTF-8 から UTF-16 への変換Utf8 To Utf16 — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- UUdecode デコーダーDecode UUencoded text。無料、プライベート、100%クライアントサイド。ツール
- UUencode エンコーダーUUencode text for Unix-to-Unix transfer。無料、プライベート、100%クライアントサイド。ツール
- Xxdecode デコーダー本サイトの XXEncode ツールが生成した xxencode テキストをデコードします。行長プレフィックス文字を含む標準的な xxencode 出力はサポートされておらず、プレフィックスはデータとしてデコードされてしまいます。ツール
- Xxencode エンコーダーxxencode 文字セット(+ - 0-9 A-Z a-z)で 3 対 4 グループ化によりテキストをエンコードします。標準の行長プレフィックス行は出力されないため、他の xxencode 実装との往復変換がうまくいかない場合があります。ツール
- Ydecode デコーダーyEnc テキスト(文字オフセット -42、「=」をエスケープとして扱う)をデコードします。エッジケース: 末尾に孤立した「=」があると、エラーにならず予期しないバイトにデコードされます。ツール
- Yencode エンコーダーYencode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Z85 デコーダーZ85 Decode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール
- Z85 エンコーダーZ85 Encode — 純クライアントサイドツール。プライバシーファースト、サーバー往復なし。ツール