Références techniques 200
Aide-mémoire, références rapides et résumés de spécifications — matériel de consultation sur le codage, les formats et les flux de travail de développement.
Configuration 3
Chiffrement/Sécurité 28
- AES Bloc Chiffre Modes Référence
- Authenticated Chiffrement (AEAD) Référence
- Authenticated Chiffrement Modes (AEAD)
- Bloc Chiffre Référence Guide
- Camellia Bloc Chiffre Specification
- ChaCha20 Stream Chiffre Specification
- Chiffre Algorithme Comparaison
- Cryptographic Attack Types Référence
- Cryptographic Clé Management Référence
- Cryptographic Clé Taille Recommendations
- ECDH (Elliptic Curve Diffie-Hellman) Référence
- ECDSA (Elliptic Curve Digital Signature Algorithme) Référence
- Elliptic Curve Cryptography Référence
- Spécification HKDF (RFC 5869)
- Homomorphic Chiffrement Référence
- Lattice-Based Cryptography Référence
- NIST Cryptographic Standards Référence
- Padding Schemes Référence
- Post-Quantum Cryptography Référence
- Provable Sécurité Référence
- RSA Clé Formats Référence
- Salsa20 Stream Chiffre Specification
- Secret Sharing Schemes Référence
- Serpent Bloc Chiffre Specification
- Side-Channel Attack Référence
- Stream Chiffre Référence Guide
- Twofish Bloc Chiffre Specification
- Zero-Knowledge Proof Référence
Encodage/Décodage 10
Formatage/Conversion 33
- Spécification Apache Avro
- Apple Propriété List (plist) Formater Guide
- Atom Syndication Formater Specification
- CBOR (Concise Binary Objet Representation) Specification
- CSV Formater RFC 4180
- Environment Variable Fichier (.env) Formater Guide
- Guide Frontmatter (YAML/TOML/JSON)
- GraphQL Requête Language Référence
- GraphQL Schéma Définition Référence
- Spécification HATEOAS / HAL
- Spécification HJSON (Human JSON)
- INI Fichier Formater Guide
- INI Formater Référence
- Java Propriétés Fichier Formater Guide
- Spécification JSON RFC 8259
- JSON Schéma Draft 2020-12
- Spécification JSON:API
- Spécification JSON5
- JSONC (JSON avec Comments) Specification
- Spécification MessagePack
- Spécification NDJSON (Newline Delimited JSON)
- OpenAPI Specification Référence
- Protocol Buffers Codage Référence
- Spécification Protocol Buffers
- Spécification RSS 2.0
- SVG Path Données Référence
- TOML Formater Specification
- Guide des espaces de noms XML
- XML Namespace Référence
- XPath Référence
- XQuery Référence
- XSLT Référence
- Spécification YAML 1.2
Hachage/Somme de contrôle 21
- Argon2 Specification Référence
- BLAKE Family Référence
- Checksum Algorithmes Référence
- Cryptographically Sûr Random Nombre Référence
- Entropy et Information Théorie Référence
- Hachage Algorithme Sortie Sizes
- Hachage Fonction Comparaison Référence
- Hachage Fonction Sécurité Propriétés
- Hachage Performance Benchmarking Référence
- HMAC (Keyed-Hachage Message Authentication) Référence
- HMAC Construction Détails (RFC 2104)
- Keccak Permutation Référence
- Clé Derivation Fonction Référence
- Merkle Hachage Tree Référence
- Non-Cryptographic Hachage Référence
- Parallel et Tree Hashing Référence
- Mot de passe Hashing Comparaison
- Mot de passe Hashing Référence
- SHA-2 Family Référence
- SHA-3 Family Référence
- Sponge Construction Référence
Math/Unités 10
Réseau/IP 31
- CORS (Cross-Origin Resource Sharing) Référence
- CORS Headers Référence
- DNS Protocol Référence
- DTLS Protocol Référence
- Ethernet et ARP Référence
- gRPC Protocol Référence
- HTTP Sécurité Headers Référence
- HTTP Status Codes Compléter Référence
- HTTP/1.1 Référence
- HTTP/2 Référence
- HTTP/3 Référence
- ICE Protocol Référence
- IP Protocol Référence
- Spécification JSON-RPC 2.0
- MIME Types Compléter List
- MQTT Protocol Référence
- NAT (Network Address Translation) Référence
- OCSP Protocol Référence
- Port Nombres Référence
- QUIC Protocol Référence
- REST API Design Référence
- RTP Protocol Référence
- SDP (Session Description Protocol) Référence
- SOAP Protocol Référence
- STUN Protocol Référence
- TCP Protocol Référence
- TLS 1.3 Référence
- UDP Protocol Référence
- Syntaxe URL RFC 3986
- WebSocket Protocol Référence
- X.509 Certificate Formater Référence
Expression régulière 20
- Caractère Codage History Référence
- Commun Regex Motifs Référence
- Regex Avancé Syntax Référence
- Regex Caractère Classes Référence
- Regex Date et Time Motifs Référence
- Regex Email Motifs Référence
- Regex Engine Comparaison Référence
- Regex Flags Référence
- Regex IP Address Motifs Référence
- Guide de performance Regex
- Regex Phone Nombre Motifs Référence
- Regex Quantifiers Référence
- Regex Syntax Aide-mémoire
- Regex Unicode Référence
- Regex URL Motifs Référence
- Chaîne Algorithme Référence
- Texte Codage Référence
- Unicode Collation Référence
- Unicode Normalization Référence
- Unicode Propriété Escapes en Regex
Sécurité 25
- API Sécurité Best Practices Référence
- Content Sécurité Policy (CSP) Référence
- Cookie Sécurité Référence
- CORS Sécurité Référence
- Cryptographic Standards Référence
- CSRF Prevention Référence
- CVE (Commun Vulnerabilities et Exposures) Référence
- CVSS (Vulnerability Scoring) Référence
- CWE (Commun Weakness Enumeration) Référence
- HSTS (HTTP Strict Transport Sécurité) Référence
- Insecure Deserialization Prevention Référence
- JWT Sécurité Référence
- NIST Clé Management Référence
- OAuth 2.0 Référence
- OpenID Connect Référence
- OWASP API Haut 10 Référence
- OWASP Haut 10 Référence
- Mot de passe Storage Référence
- Post-Quantum Algorithmes Référence
- Rate Limiting Référence
- Side-Channel Mitigation Référence
- SQL Injection Prevention Référence
- SSRF Prevention Référence
- Subresource Integrity (SRI) Référence
- XSS Prevention Référence
SQL 19
- ACID vs BASE Semantics Référence
- CAP Theorem et NoSQL Référence
- Base de données Normalization Référence
- Base de données Sharding et Partitioning Référence
- NoSQL Base de données Comparaison
- SQL Clause Référence
- SQL Constraint Référence
- SQL Données Types Référence
- SQL Fonction Référence
- SQL Fonctions Référence
- SQL Index Référence
- SQL JOIN Référence
- SQL Keywords Compléter Référence
- SQL Operator Référence
- SQL Standard Référence
- SQL Subquery et CTE Référence
- SQL Transaction et Isolation Référence
- SQL Trigger Référence
- SQL Window Fonction Référence