Encodage/DécodageOutils
Encodez et décodez des données dans divers formats : Base64, URL, Hex, Binary, entité HTML, Unicode, Base32/58/85, etc.
69 outils disponibles, tous en local dans le navigateur.
- Table ASCIIComplete ASCII reference table (0-127) with decimal, hex, octal, binary, and character. Gratuit, privé et 100% côté client.OUTIL
- Décodeur Ascii85Ascii85 Decode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur Ascii85Ascii85 Encode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Convertisseur de base numériqueConvert numbers between any base (2-36). Gratuit, privé, 100% côté client.OUTIL
- Décodeur Base100Base100 Decode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur Base100Base100 Encode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur Base2048Base2048 Decode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur Base2048Base2048 Encode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur Base32Decode Base32 (RFC 4648) back to readable text online. Gratuit, privé et 100% côté client.OUTIL
- Encodeur Base32Encode text to Base32 (RFC 4648) online. Gratuit, privé et 100% côté client.OUTIL
- Décodeur Base36Base36 Decode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur Base36Base36 Encode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur Base58Decode Base58 (Bitcoin alphabet) back to readable text online. Gratuit, privé et 100% côté client.OUTIL
- Encodeur Base58Encode text to Base58 (Bitcoin alphabet) online. Gratuit, privé et 100% côté client.OUTIL
- Décodeur Base62Base62 Decode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur Base62Base62 Encode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur Base64Decode Base64 data back to readable text online. Gratuit, privé et 100% côté client.OUTIL
- Encodeur Base64Encode text or binary data to Base64 online. Gratuit, privé et 100% côté client.OUTIL
- Décodeur Base85Decode Ascii85 (Base85) back to readable text online. Gratuit, privé et 100% côté client.OUTIL
- Encodeur Base85Encode text to Ascii85 (Base85) online. Gratuit, privé et 100% côté client.OUTIL
- Décodeur Base91Decode Base91 encoded text. Gratuit, privé, 100% côté client.OUTIL
- Encodeur Base91Encode text to Base91. Gratuit, privé, 100% côté client.OUTIL
- Décodeur binaireDecode binary (base-2) back to readable text online. Gratuit, privé et 100% côté client.OUTIL
- Encodeur binaireEncode text to binary (base-2) online. Gratuit, privé et 100% côté client.OUTIL
- Référence des jeux de caractèresReference table of character encodings. Gratuit, privé, 100% côté client.OUTIL
- Décodeur GSMGsm Decode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur GSMEncode le texte en hex GSM 03.38 via l’alphabet par défaut comme table de recherche par caractère (@ → 00, A → 41). Chaque caractère occupe un octet — aucun empaquetage 7 bits SMS n’est effectué, la sortie n’est donc pas un PDU ; les caractères hors GSM retombent en octets UTF-8.OUTIL
- Décodeur hexadécimalDecode hexadecimal back to readable text online. Gratuit, privé et 100% côté client.OUTIL
- Encodeur hexadécimalEncode text to hexadecimal online. Gratuit, privé et 100% côté client.OUTIL
- Décodeur d'entités HTMLDecode HTML entities back to readable text online. Gratuit, privé et 100% côté client.OUTIL
- Encodeur d'entités HTMLEncode text to HTML entities online. Gratuit, privé et 100% côté client.OUTIL
- Encodeur JWTCoder JWT with HS256. Free, private, 100% client-side. Not for server-side verification.OUTIL
- Décodeur d'en-têtes MIMEMime Decode Header — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur MIMEDecode MIME-encoded text (Base64 or Quoted-Printable) back to original content. Gratuit, privé et 100% côté client.OUTIL
- Encodeur d'en-têtes MIMEMime Encode Header — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur MIMEEncode text to MIME format (Base64 or Quoted-Printable) for email content. Gratuit, privé et 100% côté client.OUTIL
- Convertisseur de code MorseConvert text to Morse code and back. Gratuit, privé, 100% côté client.OUTIL
- Décodeur MultibaseMultibase Decode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur MultibaseMultibase Encode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur octalConvert octal (base-8) bytes back to text. Gratuit, privé, 100% côté client.OUTIL
- Encodeur octalConvert text to octal (base-8) byte representation. Gratuit, privé, 100% côté client.OUTIL
- Décodeur PCTPct Decode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur PCTPct Encode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur PunycodeDecode Punycode (RFC 3492) text back to Unicode. Gratuit, privé et 100% côté client.OUTIL
- Encodeur PunycodeEncode Unicode text to Punycode (RFC 3492) with ACE prefix. Gratuit, privé et 100% côté client.OUTIL
- Décodeur Quoted-PrintableDecode Quoted-Printable text back to original content. Gratuit, privé et 100% côté client.OUTIL
- Encodeur Quoted-PrintableEncode text to Quoted-Printable format (RFC 2045). Gratuit, privé et 100% côté client.OUTIL
- ROT13 / Chiffre de CésarROT13 and configurable Caesar cipher for text. Gratuit, privé, 100% côté client.OUTIL
- Convertisseur UnicodeConvert text to Unicode code points, UTF-8 hex, or UTF-16 hex online. Gratuit, privé et 100% côté client.OUTIL
- Échappement UnicodeUnicode Escape — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Déséchappement UnicodeUnicode Unescape — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur de composant URLUrl Decode Component — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur de formulaire URLUrl Decode Form — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur d'URLDecode percent-encoded URL text back to readable characters. Gratuit, privé et 100% côté client.OUTIL
- Encodeur de composant URLUrl Encode Component — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur de formulaire URLUrl Encode Form — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur d'URLPercent-encode text for safe use in URLs. Gratuit, privé et 100% côté client.OUTIL
- D'UTF-16 à UTF-8Utf16 To Utf8 — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur UTF-7Décode l’UTF-7 modifié (RFC 2152) en texte : les séquences décalées +base64- redeviennent leurs caractères. Limitation connue : l’échappement « +- » pour un plus littéral se décode en rien au lieu de « + ».OUTIL
- Encodeur UTF-7Encode le texte en UTF-7 modifié (RFC 2152) : l’ASCII passe tel quel, le non-ASCII devient des blocs décalés +base64-. Notez que « + » lui-même est encodé comme la séquence décalée « +ACs- » plutôt que la forme plus courte « +- », et que des caractères non-ASCII consécutifs peuvent être émis en blocs séparés.OUTIL
- D'UTF-8 à UTF-16Utf8 To Utf16 — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur UUdecodeDecode UUencoded text. Gratuit, privé, 100% côté client.OUTIL
- Encodeur UUencodeUUencode text for Unix-to-Unix transfer. Gratuit, privé, 100% côté client.OUTIL
- Décodeur XxdecodeDécode le texte xxencode produit par l’outil XXEncode de ce site. La sortie xxencode standard comportant des caractères de préfixe de longueur de ligne n’est pas prise en charge — le préfixe serait décodé comme données.OUTIL
- Encodeur XxencodeEncode le texte avec le jeu de caractères xxencode (+ - 0-9 A-Z a-z) par regroupement 3 vers 4. Aucune ligne de préfixe de longueur standard n’est émise : la sortie peut ne pas faire l’aller-retour avec d’autres implémentations xxencode.OUTIL
- Décodeur YdecodeDécode le texte yEnc (décalage de caractères -42, « = » comme échappement). Cas limite : un « = » isolé en fin d’entrée se décode en un octet inattendu au lieu de lever une erreur.OUTIL
- Encodeur YencodeYencode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Décodeur Z85Z85 Decode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL
- Encodeur Z85Z85 Encode — outil 100% côté client. Confidentialité d'abord, sans aller-retour serveur.OUTIL